0

Tips & Tricks : Installing PHP Xdebug on openSUSE with pecl

-

If you need to install Xdebug on openSUSE and don’t want ot use existing binary repo easiest way is to use pecl to do that and here is how…

First install all required packages

dev-lnx-02:~ # zypper --non-interactive install gcc autoconf automake php5 php5-pear php5-devel

Now we can download and install Xdebug itself:

(more…)

0

Tips & Tricks : Yii framework update issue

-

When Yii-based project doesn’t want to update, there might be missing component.

Once you add one plugin everything goes back to normal.

[root@arb-srv-01 easyforms]# composer update
Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
- yiisoft/yii2 2.0.7 requires bower-asset/jquery 2.2.*@stable | 2.1.*@stable | 1.11.*@stable -> no matching package found.
- Installation request for yiisoft/yii2 2.0.7 -> satisfiable by yiisoft/yii2[2.0.7].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
[root@arb-srv-01 easyforms]# composer global require "fxp/composer-asset-plugin"

Changed current directory to /root/.config/composer
Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted
Using version ^1.2 for fxp/composer-asset-plugin
./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
- Installing fxp/composer-asset-plugin (v1.2.1)
Downloading: 100%

Writing lock file
Generating autoload files
[root@arb-srv-01 easyforms]#

Hope that helps.

0

Tips & Tricks : Installing PHP Xdebug on openSUSE from existing repo

-

While using PhpStorm I tried to use remote PHP interpreter on my dev virtual machine. As I’m big openSUSE fan and user I have openSUSE Leap 42.1 as my development machine. Unfortunately there is no Xdebug for PHP distributed by default.

However, there is repository available, so it’s easy to add this missing component to my system.

Here is how…

(more…)

0

Tips & Tricks : Introduction to Laravel : Free coding tools

-

In previous articles:

we created and published web project.

Now it’s time to try to do some development and modify out-of-the-box project to create our own application.

Question is what tools should we use to start code development.

You might want to have a look at two available for free:

Sublime Text

Download from: http://www.sublimetext.com

Sublime Text

Visual Studio Code

Download from: http://code.visualstudio.com

Visual Studio Code


Both apps can highlight syntax for PHP-based code, so both can be used for development purposes with Laravel web application.

Check them and decide which one will be better fit for you.

0

How-to : Introduction to Laravel : Publish Laravel Framework project on Apache 2.4

-

In previous article “How-to : Introduction to Laravel : Create a Laravel Framework project on openSUSE Leap 42.1” we’ve created Laravel project called demo-project.

However, this project is not available on web server, so we can’t open it in web browser and see it’s content.

Let’s configure Apache server to serve our demo-project.

In this article we will:

  • Place project files in appropriate folder
  • Adjust files ownership for proper publishing
  • Create configuration for Apache, so our content will be available

Let’s get to work…

(more…)

0

How-to : Introduction to Laravel : Create a Laravel Framework project on openSUSE Leap 42.1

-

It’s a simple step-by-step tutorial, how to setup Laravel project on openSUSE 42.1.

First some requirements to be able to proceed with all steps:

  • openSUSE server (I have it as virtual machine with openSUSE LEap 42.1)
  • Apache web server install on openSUSE (# zypper install apache2)
  • PHP >= 5.5.9 (# zypper install php5)
  • OpenSSL PHP Extension (# zypper install php5-openssl)
  • PDO PHP Extension (# zypper install php5-pdo)
  • Mbstring PHP Extension (# zypper install php5 mbstring)
  • Tokenizer PHP Extension (# zypper install php5-tokenizer)
  • Phar PHP Extension (# zypper install php5-phar)

Once all above are installed we can install composer.phar and then Laravel Framework

(more…)

Page 1 of 41234